Stream: Coq Platform devs & users

Topic: serapi requires ppxlib and sexplib downgrade


view this post on Zulip Michael Soegtrop (Jul 12 2022 at 10:17):

The latest serapi (coq-serapi.8.16+rc1+0.16.0) requires (again) a downgrade of ppxlib and sexplib:

  - downgrade sexplib0                     v0.15.1 to v0.14.0 [required by ppx_sexp_conv, sexplib]
  - downgrade ppxlib                       0.27.0 to 0.25.1   [required by ppx_import, ppx_deriving_yojson, ppx_sexp_conv]

Is this really required?

@Enrico Tassi : do you see issues with these versions for elpi?

view this post on Zulip Michael Soegtrop (Jul 12 2022 at 10:20):

(Elpi compiles fine with these versions).

view this post on Zulip Enrico Tassi (Jul 12 2022 at 11:38):

Elpi's use of ppx is very mild, if it compiles it is fine.

view this post on Zulip Enrico Tassi (Jul 12 2022 at 11:39):

Also, it is only used for debugging, and I've recently added tests for these prints as well, so if the tests pass, there should really be no problem.


Last updated: Jan 30 2023 at 11:03 UTC