Stream: Coq Platform devs & users

Topic: Coq Platform 8.14~2022.01 on macOS 10.13.6


view this post on Zulip Rich Hilliard (Feb 17 2022 at 13:43):

Has anyone been able to run Coq Platform 8.14~2022.01 on macOS 10.13.6?

I downloaded the binary installer from:
https://github.com/coq/platform/releases/tag/2022.01.0
which states:
"This installer is only compatible with macOS 10.13 or higher."
However, I get this trying to run coqtop, coqc, ..

dyld: lazy symbol binding failed: Symbol not found: ____chkstk_darwin
Referenced from: /Applications/Coq-Platform-8.14~2022.01.app/Contents/Resources/bin/coqtop (which was built for Mac OS X 11.0)
Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: ____chkstk_darwin
Referenced from: /Applications/Coq-Platform-8.14~2022.01.app/Contents/Resources/bin/coqtop (which was built for Mac OS X 11.0)
Expected in: /usr/lib/libSystem.B.dylib

view this post on Zulip Karl Palmskog (Feb 17 2022 at 14:33):

ping @Michael Soegtrop

view this post on Zulip Michael Soegtrop (Feb 17 2022 at 15:10):

This might get tricky to fix - I guess one has to teach OCaml / opam to build code for a different OS than the current one.

What definitely should work is to use the compile from sources scripts (which is reasonably fast on Mac).

Please create an issue at Coq Platform.

view this post on Zulip Théo Zimmermann (Feb 17 2022 at 15:40):

What could help would be to rely on a runner that is not macos-latest to generate the installer. GitHub also supports runners with macOS 10.15. Although if it already works fine on 10.15, then it might mean that the difference is rather between 10.13 and 10.15, in which case this won't help.

view this post on Zulip Michael Soegtrop (Feb 17 2022 at 18:10):

As far as I can tell one needs a fairly old XCode for 10.13 (9.0, see https://de.wikipedia.org/wiki/Xcode).

view this post on Zulip Rich Hilliard (Feb 18 2022 at 19:54):

Thanks everyone for the info.
I'll create an issue at Coq Platform.
I may try to compile from sources.
Looking around web, other applications have had this problem too, and that Xcode 13.1 will work. It is still available at
https://developer.apple.com/download/all/?q=Xcode%2013


Last updated: Jan 30 2023 at 11:03 UTC