Stream: Dune devs & users

Topic: dune install in multiple-packages repo


view this post on Zulip Karl Palmskog (Nov 15 2022 at 14:46):

I have two packages defined in my project, and I need manual dune commands to build and install exactly one of them. I tried the the following:

dune build @install -p only-package-needed
dune install -p only-package-needed

The first command goes fine, but the second command complains about .install files for the other package:

Error: The following <package>.install are missing:
- _build/default/other-unneeded-package.install

This doesn't happen at all with opam, so am I missing some option to dune install?

view this post on Zulip Karl Palmskog (Nov 15 2022 at 14:56):

Seems the problem is related to the opam package definition for other-unneeded-package. Is it even possible to have Dune ignore opam package definitions?

view this post on Zulip Emilio Jesús Gallego Arias (Nov 15 2022 at 15:13):

I have seen this too, no idea what is going on, I think opam uses opam install which doesn't suffer this problem.

view this post on Zulip Emilio Jesús Gallego Arias (Nov 15 2022 at 15:13):

Maybe post in Dune's support forum (github discussions)

view this post on Zulip Karl Palmskog (Nov 15 2022 at 15:20):

this seems related: https://github.com/ocaml/dune/issues/4814


Last updated: Feb 04 2023 at 02:03 UTC