Stream: coq-community devs & users

Topic: docker coq action with more recent dune


view this post on Zulip Ali Caglayan (May 08 2022 at 17:18):

Is it possible to set up the docker coq action with a more recent dune?

view this post on Zulip Ali Caglayan (May 08 2022 at 17:18):

cc @Erik Martin-Dorel

view this post on Zulip Ali Caglayan (May 08 2022 at 21:45):

Its a little annoying that opam recompiles Coq because it depends on dune if I upgrade it.

view this post on Zulip Ali Caglayan (May 27 2022 at 14:01):

@Erik Martin-Dorel I think for all the docker images, we should choose a more recent version of dune, say 3.2. Tying the dune version to Coq's lower bound will restrict users trying to use newer dune features in their plugins etc.

view this post on Zulip Karl Palmskog (May 27 2022 at 14:03):

as per this, it seems a too-recent Dune can also lead to issues: https://github.com/QuickChick/QuickChick/issues/287

view this post on Zulip Karl Palmskog (May 27 2022 at 14:06):

Erik is still busy with grading and the like, if you have specific proposals for the Docker images, it may be a good idea to do PRs/issues in the repos:

view this post on Zulip Ali Caglayan (Jun 07 2022 at 12:33):

I've created an issue here: https://github.com/coq-community/docker-base/issues/18

view this post on Zulip Ali Caglayan (Jun 07 2022 at 17:21):

Karl Palmskog said:

as per this, it seems a too-recent Dune can also lead to issues: https://github.com/QuickChick/QuickChick/issues/287

This doesn't seem to be an issue with dune, but rather a user error. Dune was being run outside the scope of a dune-project file so it complained.


Last updated: Feb 04 2023 at 03:30 UTC