Stream: Coq devs & plugin devs

Topic: nativevalues.cmi version mismatch


view this post on Zulip Jason Gross (Jul 02 2021 at 16:10):

Can someone tell me how to figure out the version of OCaml a .cmi is the compiled interface for?
See https://github.com/coq/coq/issues/14589 for context?

view this post on Zulip Guillaume Melquiond (Jul 02 2021 at 16:53):

You can just run the file command on it. It will give you a 3-digit number. 029 for 4.12, 027 for 4.10, 025 for 4.08, and so on.

view this post on Zulip Emilio Jesús Gallego Arias (Jul 02 2021 at 20:13):

Indeed, the header will tell you the version [using file of just hd] , tho, your problem is more subtle as even with the same OCaml version you could hit this checksum problem.


Last updated: Oct 16 2021 at 03:02 UTC